Biml Forums

Add Reply
Create New Topic
Cancel Reply

Title

Content

Attachments

No files uploaded

    Missing menu items with BIML Express and VS 2015

    Missing menu items with BIML Express and VS 2015

    I'm currently using BIML Express with Visual Studio 2015 to develop a SQL Server 2014 SSIS solution. It works fine on my laptop. But my development workstation at the customer site has no internet. I've installed the offline key and I can see the main BIML Express menu on the top menu bar. But I never see the options to add a new BIML file. I can only ever see the three options "Learn BIML", "About BIML Express", and "Toggle BIDS Helper Menus".

    I've tried creating a new SSIS project and I've copied my working solution from my laptop to the workstation. The menu items never appear.

    The workstation is running:

    • Windows Server 2012 R2
    • Visual Studio 2015 Shell (integrated) Version 14.0.23107.0 D14REL
    • SQL Server Data Tools 14.0.61021.0
    • BIML Express (the latest one. I re-downloaded it today.)

    I've just noticed a new issue. The BIML Express about window won't even open anymore. This is probably because I've uninstalled and re-installed the plugin so many times I've broken something. That window used to open but the other menu items still didn't appear.

    My laptop is running:

    • Windows 10
    • Visual Studio Enterprise 2015 Version 14.0.25431.01 Update 3
    • SQL Server Data Tools 14.0.61021.0
    • BIML Express build 5.0.60425.0

    I know there is another similar thread but it doesn't seem to be getting anymore attention. Apologies if this is considered spamming the forum.

    This is just a frustrating problem in that I've built my BIML automation scripts locally on my laptop while trying to sort out the server problem. But I need to be able to run them against the full copies of the databases on the customer's network. Even the ability to run the compiler from the command line would be great but it seems like that is a Mist IDE only feature and requires a license.

    RE:Missing menu items with BIML Express and VS 2015

    Hi Mike, in my case the "About biml" is not working as well, I think it is another symptom of the same problem. Not related tu unistall/install. Brgs Stefan

    RE:Missing menu items with BIML Express and VS 2015

    Hey Stefan,

    I only mention it as separate because the about window was working before and the menu items still weren't appearing.

    RE:Missing menu items with BIML Express and VS 2015

    So I finally fixed the issue. I'm not sure if I had to do everything that I did but I'll at least share my experience. I'm just happy it is working now so I'm not going to mess around with it anymore.

    The first thing I did was open Programs and Features and uninstall these programs in this order:

    1. BIML Express
    2. Microsoft SQL Server Data Tools - Visual Studio 2015
    3. Microsoft SQL Server Data Tools - enu (14.0.61021.0)
    4. Visual Studio 2015 Shell (Integrated)
    5. Visual Studio 2015 Shell (Isolated)

    Then I downloaded Visual Studio 2015 Community Edition With Update 3 from MSDN. (You have to join the Insider Dev program to download previous version of Visual Studio Community. Even if you have an MSDN subscription.) This was the full 7GB DVD ISO and not the web installer. I installed with a custom installation and selected the "SQL Server Data Tools" option. This only installs the Database Project and not SSRS, SSIS, and SSAS.

    I then installed SQL Server Data Tools 14.0.61021.0 from the DVD ISO image. I installed all 3 components: SSRS, SSIS, and SSAS. After that I started Visual Studio so it could complete the init steps and made sure I could open my existing SSIS solutions. Then I closed Visual Studio and installed BIML Express.

    After that everything seems to be working fine. I have all of the menu items, the about window appears, and I can check for errors and successfully compile my BIML solution.

    The final working configuration was:

    • Windows Server 2012 R2
    • Visual Studio 2015 Community Edition With Update 3 Version 14.0.25420.01
    • SQL Server Data Tools Version 14.0.61021.0
    • BIML Express Product Info: Varigence BimlStudio 5.0 (32-bit) Build 5.0.60425.0 Plugins: No plugins have been loaded

    It is my understanding that BIML Express does work with Visual Studio Shell which comes with SSDT when you don't already have Visual Studio installed. I'm not sure what has gone wrong in my case but hopefully this will help someone else out.

    It is possible that simply uninstalling everything and then reinstalling SSDT and VS Shell may have worked but at this point I just really need my development box working so I tried to make sure that all my bases were covered. Another possibility is that SSDT came with a version of VS 2015 that was too old and didn't support BIML Express. I had a feeling that the VS Community ISO would be a newer version which is another reason I went that route.